charge processing delayed for some stores
Incident Report for ReCharge
Resolved
This incident has been resolved.
Posted Apr 19, 2020 - 08:14 PDT
Monitoring
we have identified the issue, charges are processing and should be caught up soon.
Posted Apr 19, 2020 - 07:00 PDT
Investigating
We are currently investigating this issue.
Posted Apr 19, 2020 - 05:50 PDT
This incident affected: Charge Processing.