charge processing delayed for some stores
Incident Report for Recharge
Resolved
This incident has been resolved and all charges have been processed.
Posted Apr 21, 2020 - 08:52 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2020 - 07:16 PDT
Update
we have identified the issue, charges are processing and should be caught up soon.
Posted Apr 21, 2020 - 07:15 PDT
Investigating
We are currently investigating this issue.
Posted Apr 21, 2020 - 05:17 PDT
This incident affected: Recharge Charge Processing.