experiencing downtime across all tiers. we are currently investigating the issue.
Incident Report for Recharge
Resolved
This incident has been resolved.
Posted Nov 03, 2019 - 01:45 PST
Monitoring
we've identified the problem and have applied a fix
Posted Nov 02, 2019 - 23:56 PDT
Investigating
We are currently investigating this issue.
Posted Nov 02, 2019 - 23:38 PDT
This incident affected: Recharge API, Recharge Customer Portal, and Recharge Checkout.