Login Issues
Incident Report for Recharge
Resolved
Our Engineers have deployed a fix and merchants can now access the admin area.
Posted Jul 07, 2020 - 08:15 PDT
Investigating
We are experiencing issues where the admin area is not accessible from Shopify, our Engineers are currently working on a resolution.
Posted Jul 07, 2020 - 07:56 PDT
This incident affected: Recharge Customer Portal.