Support Ticket submission form issues
Incident Report for Recharge
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 13:17 PDT
Identified
Our technical support ticket submission form is currently down. We’re actively working on a fix and apologize for the inconvenience.
Posted Mar 21, 2023 - 12:21 PDT
This incident affected: Zendesk.