Performance Degradation
Incident Report for ReCharge
Resolved
This incident has been resolved. Thank you for your patience as we worked toward the best resolution.
Posted Sep 03, 2020 - 08:11 PDT
Monitoring
A fix has been implemented and we are closely monitoring the results.
Posted Sep 03, 2020 - 07:43 PDT
Investigating
We are experiencing performance degradation across all services. Our Support Engineers are working towards a resolution.
Posted Sep 03, 2020 - 07:02 PDT
This incident affected: ReCharge API, ReCharge Admin panel, and ReCharge Checkout.