ReCharge Merchant Portal issues
Incident Report for Recharge
Resolved
Merchant portal issue has been resolved and is now fully functional.
Posted Jul 28, 2020 - 15:01 PDT
Update
We are continuing to investigate this issue.
Posted Jul 28, 2020 - 14:52 PDT
Investigating
Merchants have reported issues navigating the ReCharge merchant portal.
Posted Jul 28, 2020 - 14:49 PDT
This incident affected: Recharge Customer Portal.