Issue in creating/editing subscriptions
Incident Report for Recharge
Resolved
This incident has been resolved.
Posted Dec 30, 2019 - 08:07 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 30, 2019 - 07:42 PST
Investigating
We are aware of an issue in admin creating/editing subscriptions and are investigating.
Posted Dec 30, 2019 - 07:31 PST
This incident affected: Recharge Customer Portal.