Search on admin and customer portal is down therefore add/swap not working currently
Incident Report for ReCharge
Resolved
This incident has been resolved. Thank you greatly for your patience.
Posted Sep 08, 2020 - 12:12 PDT
Identified
The issue has been identified and a fix has been deployed
Posted Sep 08, 2020 - 11:59 PDT
This incident affected: ReCharge Admin panel.