Degraded Performance
Incident Report for ReCharge
Resolved
Caching issues resolved. Performance is restored.
Posted Jan 15, 2020 - 08:37 PST
Investigating
We are currently investigating. Appears to be caching issues leading to degraded performance.
Posted Jan 15, 2020 - 08:33 PST