Manage Subscription Errors
Incident Report for Recharge
Resolved
We are observing full recovery and will continue monitoring.
Posted Jan 29, 2022 - 09:47 PST
Identified
The issue has been identified and our engineering team is working to resolve.
Posted Jan 29, 2022 - 09:16 PST
Investigating
We are receiving reports of issues with subscription management on Novum, and are currently investigating.
Posted Jan 29, 2022 - 08:01 PST
This incident affected: Recharge Merchant Portal.