Customer Portal issue
Incident Report for Recharge
Resolved
The issue with the customer portal has been resolved.
Posted Nov 11, 2022 - 05:06 PST
Monitoring
Our engineering team has identified the issue and deployed a fix.
Posted Nov 11, 2022 - 04:52 PST
Investigating
We are currently investigating the issue with our customer portal where some options aren't accessible.
Posted Nov 11, 2022 - 04:19 PST
This incident affected: Recharge Customer Portal.