Help Center access issues for some users
Incident Report for Recharge
Resolved
The CDN provider has implemented a fix and this issue has been resolved.
Posted Oct 25, 2022 - 11:54 PDT
Identified
Due to an issue with a content delivery network provider some merchants may experience errors when accessing our Help Center. We are working alongside them to mitigate the impact and will provide more information shortly.
Posted Oct 25, 2022 - 10:43 PDT