We're currently investigating issues related to checkout performance impacting a subset of merchants.
Incident Report for Recharge
Resolved
This issue has been resolved. Thank you for your understanding and patience.
Posted Jan 04, 2021 - 14:17 PST
Monitoring
We have implemented a fix and are continuing to monitor performance
Posted Jan 04, 2021 - 13:57 PST
Investigating
We’re currently investigating issues related to checkout performance impacting a subset of merchants.
Posted Jan 04, 2021 - 13:29 PST
This incident affected: Recharge Checkout.