Resolved | Minor issue
Incident Report for Recharge
Resolved
We've identified and resolved a minor issue that partially impacted the Customer details page on Admin dashboard for a portion of our merchants.
Posted Jul 12, 2021 - 07:13 PDT