Customer Portal issue
Incident Report for Recharge
Resolved
This incident has been resolved.
Posted Nov 12, 2021 - 05:13 PST
Monitoring
The issue has been resolved and we are monitoring recovery.
Posted Nov 12, 2021 - 05:07 PST
Investigating
We have identified an issue with the Customer Portal and are unable to update CC details and are working to resolve it.
Posted Nov 12, 2021 - 04:40 PST
This incident affected: Recharge Customer Portal.