Checkout Degradation
Incident Report for ReCharge
Resolved
The issues on checkout have been resolved
Posted Jan 20, 2021 - 09:32 PST
Investigating
We’re experiencing issues on checkout as a result of upstream performance issues with one of our partners.
Posted Jan 20, 2021 - 07:40 PST
This incident affected: ReCharge Checkout.