ReCAPTCHA Failure
Incident Report for Recharge
Resolved
This incident has been resolved.
Posted Jun 16, 2022 - 13:47 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2022 - 11:33 PDT
Investigating
We are receiving reports of issues with ReCAPTCHA and are investigating.
Posted Jun 16, 2022 - 11:29 PDT
This incident affected: Recharge Checkout.