Checkout issue
Incident Report for ReCharge
Resolved
This incident has been resolved.
Posted Aug 26, 2020 - 10:31 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2020 - 10:22 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 26, 2020 - 10:18 PDT
Investigating
We are currently investigating reports that the Place My Order button on some checkouts is not functional.
Posted Aug 26, 2020 - 10:11 PDT
This incident affected: ReCharge Checkout.