Error When Adding Products
Incident Report for Recharge
Resolved
We have identified the issue and deployed a fix.
Posted Jun 30, 2020 - 09:32 PDT
Investigating
We are investigating reports from customers related to failures when adding products to subscriptions from the admin panel
Posted Jun 30, 2020 - 09:00 PDT