Customer Portal Credit Card update
Incident Report for Recharge
Resolved
This incident has been resolved
Posted Oct 29, 2020 - 13:48 PDT
Identified
The issue has been identified the fix is being implemented.
Posted Oct 29, 2020 - 13:31 PDT
Investigating
We are investigating reports of customers and merchants unable to update credit cards from the customer portal
Posted Oct 29, 2020 - 13:21 PDT