Updating Domain for Recharge Support
Incident Report for Recharge
Resolved
Our support domain is now up to date. Thank you for your patience.
Posted Dec 21, 2022 - 08:31 PST
Identified
Our team is in the process of updating the rechargesupport.com domain. If you're unable to create a support ticket from that domain, please use the 'Contact Us' button on support.rechargepayments.com/ in the meantime.
Posted Dec 21, 2022 - 07:26 PST
This incident affected: Recharge Payments website.