Service Degraded on Customer Portal Subscription page.
Incident Report for Recharge
Resolved
We have confirmed recovery on the admin tier and will continue to observe.
Posted Jan 04, 2021 - 10:32 PST
Monitoring
Service Degraded on Customer Portal Subscription page, we are working on it and deploying a fix now.
Posted Jan 04, 2021 - 09:02 PST
This incident affected: Recharge Customer Portal.