Degraded State/Slow Response Times
Incident Report for ReCharge
Resolved
We have identified the underlying issue and are in recovery, we will continue to monitor closely
Posted May 04, 2021 - 08:00 PDT
Identified
We are currently experiencing degraded state which may result in slow response times.
Posted May 04, 2021 - 07:44 PDT