Delayed Widget Load Time
Incident Report for Recharge
Resolved
We experienced issues related to our CDN and are now in full recovery, Engineering continuing to observe
Posted Jul 20, 2021 - 11:13 PDT
Investigating
We are currently investigating an issue where the Recharge widget is loading slowly.
Posted Jul 20, 2021 - 08:48 PDT